Beantwoord

Cloud en php-mailscript

  • 31 mei 2016
  • 22 reacties
  • 806 keer bekeken

Ik kom er met de zakelijke cloud helpdesk niet uit.

Al maanden draaien er verschillende mailscripts op onze bedrijfswebsite die prima werkten. Ineens hielden ze er allen afgelopen maandag allen mee op. De scripts verzenden een email met websresponse. Op de helpdesk ontkent men dat er iets fout is aan de hosting kant van KPN. We hebben onze website even op een tijdelijke andere host gezet en daar mailt php alles prima.....

Het verschil dat ik in phpinfo (); zie tussen KPN-hosting en da andere host is:

KPN: sendmail_path    no value

Andere host: sendmail_path    /usr/sbin/sendmail -t -i

Is dat het probleem...?
icon

Beste antwoord door Tim 30 juni 2016, 13:20

Beste Ed1966,

Het probleem is opgelost op 28-06! De terugkoppeling van de leverancier:
"Main reason of the email delay was a problem with SPAM. The used mail relay didn't discriminate, so when a SPAM round was detected, the mail relay shut down all the mail transport.
What we have done is implement a filter in the mail relay that avoids this situation in the future. The mail relay will only filter the SPAM IP and not the platform completely"

Inderdaad ben ik vrij kort door de bocht gegaan met mijn opmerking over de aansprakelijkheid. Het is ook niet dat ik u klacht afwijs, persoonlijk ben ik het met u eens. KPN heeft het probleem niet tijdig erkent waardoor u kosten heeft gemaakt. Daarom is een tegemoetkoming in deze kosten absoluut iets waar wij aan moeten meewerken. Om terug te komen op uw klacht, deze heb ik zojuist doorgezet naar een klachtbehandelaar. Binnen 10 werkdagen neemt mijn collega contact met u op om te kijken naar een tegemoetkoming voor de ondervonden schade. De klacht staat bij ons geregistreerd met nummer 1-49322314132.

Als u vragen hebt, verneem ik graag uw reactie.
Bekijk origineel

22 reacties

Reputatie 7
Badge +11
Hi @Ed1966, leuk dat u deze vraag op het forum stelt! :D

Vreemd dat de functie sinds gisteren niet meer werkt. Ook ik moet ontkennen dat het probleem aan de hosting kant van KPN kan liggen. Het geval is namelijk dat onze hosting werkt op basis van "Shared hosting". U heeft niet de mogelijkheid om PHP zelf te installeren of te configureren. Op elke server wordt een gedeelde PHP installatie gebruikt. Er zijn de afgelopen dagen geen wijzigingen geweest binnen de webhosting van KPN.

Als sendmail_path inderdaad geen waarde geeft, is dit ook defect voor andere gebruikers. Er zijn nog geen andere meldingen ontvangen. Om deze reden verwacht ik dat het probleem bijvoorbeeld in het script moet zitten.

phpinfo() op Linux Webhosting bij KPN:

sendmail.PNG

Neemt u wellicht Windows hosting af? Daar heb ik momenteel geen account van bij de hand om te testen namelijk. Ik verneem graag uw reactie!
https:///t5/user/viewprofilepage/user-id/227 schreef op https:///t5/Cloud-technische-vragen/Cloud-en-php-mailscript/m-p/8106#M1563Hi https:///t5/Cloud-technische-vragen/Cloud-en-php-mailscript/m-p/8100, leuk dat u deze vraag op het forum stelt! Smiley Vrolijk

Vreemd dat de functie sinds gisteren niet meer werkt. Ook ik moet ontkennen dat het probleem aan de hosting kant van KPN kan liggen. Het geval is namelijk dat onze hosting werkt op basis van "Shared hosting". U heeft niet de mogelijkheid om PHP zelf te installeren of te configureren. Op elke server wordt een gedeelde PHP installatie gebruikt. Er zijn de afgelopen dagen geen wijzigingen geweest binnen de webhosting van KPN.

Als sendmail_path inderdaad geen waarde geeft, is dit ook defect voor andere gebruikers. Er zijn nog geen andere meldingen ontvangen. Om deze reden verwacht ik dat het probleem bijvoorbeeld in het script moet zitten.

phpinfo() op Linux Webhosting bij KPN:

sendmail.PNG

Neemt u wellicht Windows hosting af? Daar heb ik momenteel geen account van bij de hand om te testen namelijk. Ik verneem graag uw reactie!

 Beste Tim, onze website is www.ace-management-partners.nl. Als ik daarop phpinfo (); vraag (is inderdaad bovenstaande lijst) dan krijg ik bij sendmail_path "no value". Test maar op :

http://www.ace-management-partners.nl/testomgeving/phpinfo.php

Alle scripts werkten de afgelopen 2 maanden prima, en ineens miv afgelopen maandag was het mis. We hebben een kopie vd website op een andere host gezet en daar geven de scripts geen problemen en werken normaal... We hebben nu een noodoplossing dat de site bij KPN gehost wordt en dat de phpscripts bij een andere hoster vandaan worden gehaald in een iframe. Dat werkt voor nu even tot we wss migreren...
Reputatie 7
Badge +11
Hallo @Ed1966, sorry voor mijn late reactie. Het het systeem maak ik op dat u de verhuiscode voor uw domein heeft aangevraagd. Jammer uiteraard dat u vertrekt maar gezien het missen van https/ssl begrijp ik uw motivatie.

U heeft mij weten te overtuigen met bovenstaande bericht. U neemt Windows hosting af en daar zie ik ook bij een test account dat er geen waarde is toegewezen aan sendmail_path. Of dit de oorzaak is weet ik niet te zeggen. Ondertussen heb ik al met enkele collega's naar dit verschijnsel gekeken. We hebben besloten om een hulpvraag hierover uit te zetten bij de leverancier. Daar heb ik nog geen reactie op. Zodra ik meer weet, meld ik mij in dit topic!
https:///t5/user/viewprofilepage/user-id/227 schreef op https:///t5/Cloud-technische-vragen/Cloud-en-php-mailscript/m-p/8131#M1581Hallo https:///t5/Cloud-technische-vragen/Cloud-en-php-mailscript/m-p/8100, sorry voor mijn late reactie. Het het systeem maak ik op dat u de verhuiscode voor uw domein heeft aangevraagd. Jammer uiteraard dat u vertrekt maar gezien het missen van https/ssl begrijp ik uw motivatie.

U heeft mij weten te overtuigen met bovenstaande bericht. U neemt Windows hosting af en daar zie ik ook bij een test account dat er geen waarde is toegewezen aan sendmail_path. Of dit de oorzaak is weet ik niet te zeggen. Ondertussen heb ik al met enkele collega's naar dit verschijnsel gekeken. We hebben besloten om een hulpvraag hierover uit te zetten bij de leverancier. Daar heb ik nog geen reactie op. Zodra ik meer weet, meld ik mij in dit topic!

 Ik kom mij ook even melden aangezien ik hetzelfde probleem heb, laatste ontvangen mail via de website was 11-05-2016, van de week via een klant tehoren gekregen dat ze geen reactie terug kregen op de mails die ze stuurden.

http://gerritsen-parket.nl/phpinfo.php

Het formulier die het eerst altijd deed:

http://gerritsen-parket.nl/Formulier.htm

test formulieren via andere scripten:

http://gerritsen-parket.nl/contact/contact.php

http://gerritsen-parket.nl/contact/test.html
https:///t5/user/viewprofilepage/user-id/1975 schreef op https:///t5/Cloud-technische-vragen/Cloud-en-php-mailscript/m-p/8168#M1592https:///t5/user/viewprofilepage/user-id/227 schreef op https:///t5/Cloud-technische-vragen/Cloud-en-php-mailscript/m-p/8131#M1581Hallo https:///t5/Cloud-technische-vragen/Cloud-en-php-mailscript/m-p/8100, sorry voor mijn late reactie. Het het systeem maak ik op dat u de verhuiscode voor uw domein heeft aangevraagd. Jammer uiteraard dat u vertrekt maar gezien het missen van https/ssl begrijp ik uw motivatie.

U heeft mij weten te overtuigen met bovenstaande bericht. U neemt Windows hosting af en daar zie ik ook bij een test account dat er geen waarde is toegewezen aan sendmail_path. Of dit de oorzaak is weet ik niet te zeggen. Ondertussen heb ik al met enkele collega's naar dit verschijnsel gekeken. We hebben besloten om een hulpvraag hierover uit te zetten bij de leverancier. Daar heb ik nog geen reactie op. Zodra ik meer weet, meld ik mij in dit topic!

 Ik kom mij ook even melden aangezien ik hetzelfde probleem heb, laatste ontvangen mail via de website was 11-05-2016, van de week via een klant tehoren gekregen dat ze geen reactie terug kregen op de mails die ze stuurden.

http://gerritsen-parket.nl/phpinfo.php

Het formulier die het eerst altijd deed:

http://gerritsen-parket.nl/Formulier.htm

test formulieren via andere scripten:

http://gerritsen-parket.nl/contact/contact.php

http://gerritsen-parket.nl/contact/test.html

 Wij zijn inmiddels aan het migreren naar mijndomein.nl. Daar werkt de site wel gewoon en daar verkopen ze ook SSL/HTTPS, dat is belangrijk voor de ranking van je website in Google. Dat heeft KPN nog zeker een jaar niet zeggen ze.

En laat KPN-Helpdesk nu maar volhouden dat wij iets fout doen. Gewoon niet serieus genomen door 1e-lijns-KPN-support, dat is al 3 keer eerder gebeurd. Ook bij de overstap nr nieuwe cloud/hosting-systeem enorme problemen voor ons. Lag ook niet aan KPN was de 1e reactie....... En enige tijd geleden een enorm probleem gehad met frontpage extenties, zelfde verhaal..... Lag steeds aan ons en later bleek dat we toch gelijk hadden...

1e-lijn support is een niet te nemen vesting binnen KPN. Dat blijkt steeds weer. KPN doe er iets aan...!!!
Reputatie 7
Badge +11
https:///t5/user/viewprofilepage/user-id/1975 schreef op https:///t5/Cloud-technische-vragen/Cloud-en-php-mailscript/m-p/8168#M1592

Ik kom mij ook even melden aangezien ik hetzelfde probleem heb, laatste ontvangen mail via de website was 11-05-2016, van de week via een klant tehoren gekregen dat ze geen reactie terug kregen op de mails die ze stuurden.

http://gerritsen-parket.nl/phpinfo.php

Het formulier die het eerst altijd deed:

http://gerritsen-parket.nl/Formulier.htm

test formulieren via andere scripten:

http://gerritsen-parket.nl/contact/contact.php

http://gerritsen-parket.nl/contact/test.html

 

Hallo 
  • , welkom op het Zakelijk KPN Forum! Wat fijn dat u een soortgelijk probleem op het forum meldt, dat geeft ons meer voorbeelden en mogelijkheden om de oorzaak te achterhalen. Aangezien u ook melding maakt, ben ik absoluut overtuigd van een probleem op het hosting platform. Wat precies zijn we nog niet uitgekomen.

    U ben een gemigreerde klant naar het nieuwe platform. De oude servers zijn nog up & running tot de laatste accounts over zijn. Uw oude account hebben we tijdelijk weer geactiveerd en uw http://d169617.pem.kpn.net/Formulier.htm" target="_blank getest. U heeft mijn e-mail zonder problemen ontvangen! Met deze informatie is de technische dienst nu op onderzoek gegaan. Een collega neemt hierover telefonisch contact met u op.

    https:///t5/user/viewprofilepage/user-id/1947 schreef op https:///t5/Cloud-technische-vragen/Cloud-en-php-mailscript/m-p/8178#M1596

    Wij zijn inmiddels aan het migreren naar mijndomein.nl. Daar werkt de site wel gewoon en daar verkopen ze ook SSL/HTTPS, dat is belangrijk voor de ranking van je website in Google. Dat heeft KPN nog zeker een jaar niet zeggen ze.

    En laat KPN-Helpdesk nu maar volhouden dat wij iets fout doen. Gewoon niet serieus genomen door 1e-lijns-KPN-support, dat is al 3 keer eerder gebeurd. Ook bij de overstap nr nieuwe cloud/hosting-systeem enorme problemen voor ons. Lag ook niet aan KPN was de 1e reactie....... En enige tijd geleden een enorm probleem gehad met frontpage extenties, zelfde verhaal..... Lag steeds aan ons en later bleek dat we toch gelijk hadden...

    1e-lijn support is een niet te nemen vesting binnen KPN. Dat blijkt steeds weer. KPN doe er iets aan...!!!

    Beste 
  • , erg jammer natuurlijk dat u migreert naar een andere aanbieder. Ik begrijp de keuze heel goed aangezien u gebruik wenst te maken van SSL/HTTPS. De functionaliteit wordt inderdaad vermoedelijk in 2017 toegevoegd, hopelijk eerder maar enkele andere projecten hebben momenteel een hogere prioriteit.

    Soms is het lastig om uit te sluiten of een probleem in het script van een gebruiker zit of op het hosting platform. Dit kan voor u als klant inderdaad best lastig zijn. Het frontpage extenties issue is mij ook bekend, we hebben tot 4 keer de leverancier moeten overtuigen dat er een probleem was met een module op een bepaalde server. Andere servers hadden het probleem niet. Erg vervelend dat dit zoveel moeite heeft gekost en erg lang heeft geduurt. :(

    We gaan er dit keer snel uitkomen! Ik houd jullie op de hoogte.
  • Reputatie 7
    Badge +11
    UPDATE:
    Gebruikers met Windows (IIS) hosting en contact form scripts (PHP) die een e-mail versturen (SMTP) naar de geconfigureerde ontvanger, ontvangen het betreffende mailformulier niet.

    In eerste instantie kregen we te horen dat het content gerelateerd was zoals verwacht. Echter hebben we betreffende PHP-scripts van de gebruikers ingeladen in een Linux (Apache) hosting abonnement en hier werken ze correct. De laatste gebruikersmelding is een in Presence Builder gemaakte website met de contactformulier module van Presence Builder met hetzelfde probleem die met Linux hosting geen problemen ervaart.

    Het probleem is dus erkent en wordt aan gewerkt.
    Oke, maar in eerste instantie heeft de helpdesk van KPN ons gegarandeerd dat er fouten in onze code zaten en dat we maar eens een goede PHP-programmeur moesten inhuren om juiste code te schrijven. Wat te doen met alle extra kosten die gemaakt zijn doordat KPN ons meerdere maanden aan het lijntje heeft gehouden op basis van onjuiste informatie...? Er zitten nu ongeveer 80 manuren in deze laatste blunder van KPN. Wat doen we daar dan mee...?? Omzetverlies nog even daar gelaten...
    Reputatie 7
    Badge +11
    Beste Ed1966, dat is uiteraard niet best. Het is erg spijtig om te horen dat hier zoveel manuren verloren aan zijn geraakt. Ik snap dat u hier niet blij mee bent en een gebaar van KPN verwacht. U heeft een terecht punt. Al is het wel zo dat KPN niet aansprakelijk is voor omzet verlies en gemaakte uren. Bij het afnemen van een niet goed functionerende dienst heeft u uiteraard recht op teruggave van uw abonnementskosten. Ik stel voor dat ik u help om een klacht in behandeling te nemen. Een klachtbehandelaar kijkt dan met u naar de situatie en naar een oplossing.
    Om dan voor de klachtenbehandelaar het verhaal even compleet te maken het volgende overzicht:

    (1) In nov 2015 migreert KPN naar een nieuw hostingsysteem. Als direct gevolg daarvan valt de asp-functionaliteit van onze hele website meer dan een maand volledig uit. KPN geeft dan aan dat de code van onze asp-paginas niet goed is (verouderd) en adviseert een nieuwe website te bouwen. Daar zijn 120 manuren in gaan zitten. Later blijkt dat het niet onze fout was maar dat er toch iets in de server van KPN niet in orde was (zie uw reactie hierboven onder 8 juni). De bouw vd nieuwe website was dus overbodig.

    (2) Over punt 1 is een klacht ingediend. En toen daar geen antwoord op kwam is er een klacht ingediend dat er geen antwoord op de klacht kwam. Tot op heden (23 juni 2016) nog niets daarover gehoord. U schrijft daarover op dit forum dat de klacht in behandeling is en dat we dat even moeten afwachten. Ik wijs er graag op dat de klacht 6 maanden (!!!!) oud is... Hoe lang duurt dat wachten dan nog?

    (3) Op 31 mei vallen ineens alle PHP-script op de nieuwe website uit na 2 maanden prima gewerkt te hebben. En weer komt er een advies van de helpdesk van KPN: er zitten fouten in de code, huur maar eens een goede PHP-programmeur in. Aan de kant van KPN draait alles probleemloos en is er niets fout. Er gaan 80 manuren zitten in een tijdelijke oplossing met een andere provider (is nu definitieve oplossing geworden). En weer blijkt later (zie bovenstaand) dat er bij KPN toch iets fout was, hetgeen eerst ten stelligste ontkent werd... En de code in onze website was van het begin af aan prima in orde.

    We zitten nu al op 200 manuren die we op basis van foute adviezen van KPN hebben moeten besteden aan het oplossen van fouten die door KPN begaan zijn.

    Uiteraard hebben we recht op restitutie van abonnementsgelden. Verdere aansprakelijkheid wijst u af. Maar dat is denk ik iets te kort door de bocht. Er zijn nl een aantal zaken verwijtbaar. Plus dat er 2 keer een verkeerd advies wordt gegeven door de KPN-helpdesk (geen advies is niet verwijtbaar, een fout advies wel).

    Ik hoor graag van de klachtenbehandelaar....
    Reputatie 7
    Badge +11
    Beste Ed1966,

    Het probleem is opgelost op 28-06! De terugkoppeling van de leverancier:
    "Main reason of the email delay was a problem with SPAM. The used mail relay didn't discriminate, so when a SPAM round was detected, the mail relay shut down all the mail transport.
    What we have done is implement a filter in the mail relay that avoids this situation in the future. The mail relay will only filter the SPAM IP and not the platform completely"

    Inderdaad ben ik vrij kort door de bocht gegaan met mijn opmerking over de aansprakelijkheid. Het is ook niet dat ik u klacht afwijs, persoonlijk ben ik het met u eens. KPN heeft het probleem niet tijdig erkent waardoor u kosten heeft gemaakt. Daarom is een tegemoetkoming in deze kosten absoluut iets waar wij aan moeten meewerken. Om terug te komen op uw klacht, deze heb ik zojuist doorgezet naar een klachtbehandelaar. Binnen 10 werkdagen neemt mijn collega contact met u op om te kijken naar een tegemoetkoming voor de ondervonden schade. De klacht staat bij ons geregistreerd met nummer 1-49322314132.

    Als u vragen hebt, verneem ik graag uw reactie.
    Wat was er precies opgelost?
    phpinfo geeft nog steeds "no value" aan bij Send~
    Reputatie 7
    Badge +11
    Hallo Aapjuh, wat ik ervan begrijp is dat het mailverkeer werd stilgelegd bij het detecteren van een SPAM poging. Dit heeft voor de problemen gezorgd en is verholpen door SPAM op een andere manier tegen te gaan. Het viel ons op dat ook de oude server "no value" geen bij sendmail, dit staat los van de oorzaak en is normaal bij Windows hosting.
    Hallo Aapjuh, wat ik ervan begrijp is dat het mailverkeer werd stilgelegd bij het detecteren van een SPAM poging. Dit heeft voor de problemen gezorgd en is verholpen door SPAM op een andere manier tegen te gaan. Het viel ons op dat ook de oude server "no value" geen bij sendmail, dit staat los van de oorzaak en is normaal bij Windows hosting.

    net alle 3 de script (van mijn eerdere post) getest, geen van de 3 werken en bij formulier.htm moet ik zelfs een username en pass invullen nadat ik op verzenden klik.
    Reputatie 7
    Badge +11
    Hallo Aapjuh, dat is vreemd. Ik heb zojuist mijn collega van de technische dienst gevraagd om hier nogmaals naar te kijken. U krijgt van mij of mijn collega zo snel mogelijk bericht.
    Reputatie 7
    Badge +11
    Beste Aapjuh en andere volgers van dit topic,

    Volgens mijn informatie zou het probleem nu definitief opgelost moeten zijn. Graag hoor ik van jullie of dit inderdaad het geval is. Zodat we de leverancier kunnen melden of het opgelost is of dat we ze weer aan het werk moeten zetten. 😉
    Sorry voor de late reactie, het is inderdaad opgelost voor mij, na het testen van mijn contact formulieren kwamen de mails netjes binnen.

    Bedankt voor het oplossen van het probleem 🙂
    Reputatie 7
    Badge +11
    Fijn om te horen Aapjuh! Bedankt voor uw terugkoppeling. Om eerlijk te zijn bleek het vorige week nog niet meteen opgelost en zijn ze nog enkele dagen langer bezig geweest om het op te lossen.
    Heel blij dat het eindelijk gelukt is!
    Ik heb sinds enkele weken hetzelfde probleem. Van de mails die mijn website stuurde (naar mijzelf) kwamen ineens sommige mails niet meer door. Inmiddels ontvang ik geen enkele mail meer. Ik heb een test-php-scriptje gemaakt dat niets anders doet dan een simpel mailtje verzenden. Dat werkt dus ook niet.

    Ik gebruik overigens het Linux platform

    Vriendelijke groet,

    Stef
    Reputatie 6
    Badge +5
    Goedemorgen Stef,

    Fijn dat u ons gevonden heeft! Zou u uw domeinnaam (evt. via een privébericht) willen doorgeven?
    Dan gaan we bij u ook op onderzoek uit:)
    Helaas na lang wachten op een oplossing heb ik het opgegeven. Ik heb meerdere keren gebeld en kreeg telkens mensen aan de telefoon dit mijn probleem ontkenden. Ook van dit topic hadden ze nooit gehoord. Toen ik tenslotte tegen iemand (zijn naam is me bekend) zei dat ik naar een andere provider zou gaan werd dit enthousiast ontvangen (aanmoedigend). Hierover heb ik me erg kwaad gemaakt. De persoon in kwestie dreigde eerst de verbinding te verbreken maar draaide toen bij. Ik heb hem vervolgens twee dagen tijd gegeven om iets aan mijn probleem te doen. Hij heeft nog wel een keer teruggebeld voor nadere informatie maar opgelost werd en niets en het bleef andermaal stil. Gisteren heb ik de knoop doorgehakt en ben naar een andere provider overgestapt. Dat gaat vlot, zeg. Daar heb ik dezelfde code die ik bij KPN gebruikte ge-upload en alles werkt weer perfect. Nu alleen nog mijn abonnement opzeggen. Jammer.
    Reputatie 6
    Badge +5
    Goedemorgen Stef,

    Heel naar om te lezen hoe u bent behandeld aan de telefoon! Zou u de naam in kwestie aan mij willen toesturen via een privébericht? Dan kan ik ervoor zorgen dat dit nooit meer voorkomt.

    Ik vind het wel heel jammer dat u mijn hulp 3 maanden geleden niet hebt aangenomen. 😞 Zoals aangegeven in dit topic zijn we bekend met het feit dat dit probleem weleens voorkomt. Ik had u heel graag geholpen om het op te lossen.

    Hopelijk mag ik alsnog aan de slag voor u om er in ieder geval voor te zorgen dat dit in de toekomst niet nogmaals gebeurt. Ik hoor graag van u.

    Reageer