PHP mail komt niet aan

  • 23 april 2017
  • 19 reacties
  • 852 keer bekeken

Goedendag

Eerst maar even wat Informatie
Joomlasite opgezet met webhosting online met Linux
Systeeminformatie
Instellingen Waarde

PHP gebouwd op Linux plwww02 2.6.32-673.26.1.lve1.4.20.el6.x86_64 #1 SMP Tue Dec 27 17:42:53 EST 2016 x86_64
Database versie 5.5.52
Database collatie latin1_swedish_ci
Collatie van de databaseverbinding utf8_general_ci
PHP versie 5.5.38
Webserver Apache
WebServer naar PHP interface cgi-fcgi
Joomla! versie Joomla! 3.6.5 Stable [ Noether ] 1-December-2016 22:46 GMT
Joomla! Platform versie Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
Gebruikersagent Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

Chronoforms V5 geïnstalleerd.
Formulier gemaakt.
Formulier in homepage geplaatst. www.benstempher.nl onderaan als testformulier
alles is ingesteld op PHP mail
Binnen algemene instellingen tab "server " een testmail verzonden
Melding"E-mail verzenden naar bloembinderij@benstempher.nl met behulp van PHP mail is gelukt. Controleer of u de test e-mail hebt ontvangen."
Die mail komt niet aan
Gaan we het testformulier invullen en versturen dan krijg ik de melding
"testformulier
Dank U voor het versturen van het formulier

Data Array

Array
(
[chronoform] => proberen
[event] => submit
[name] => Frans de Vries
[email] => vriesf@hotmail.com
[subject] => testingmail
[bericht] => This is a testing mail for cotrole the delivery
[submit] => Verzenden
[ip_address] => 217.121.182.98
)

Array
(
)

Errors

Array
(
)

Debug Info

Array
(
[6] => Array
(
[Email] => Array
(
[0] => An email with the details below was sent successfully:
[1] => To:bloembinderij@benstempher.nl
[2] => Subject:subject
[3] => From name:Ben Stempher
[4] => From email:bloembinderij@benstempher.nl
[5] => CC:
[6] => BCC:
[7] => Reply name:
[8] => Reply email:
[9] => Attachments:
[10] => Array
(
)

[11] => Body:

Frans de Vries

vriesf@hotmail.com

testingmail

This is a testing mail for cotrole the delivery



IP: 217.121.182.98
)

)

)

Het is een hoop info maar misschien heeft iemand een idee!
Ps
Alle zelf geinstalleerde extenties zijn hierbij uitgeschakeld m.u.v. chronoforms natuurlijk

19 reacties

Reputatie 7
Badge +6
Ik heb de DNS Records bekeken:
code:
PS C:\Users\LocalAdmin> Resolve-DnsName -Name "benstempher.nl" -type "txt"

Name Type TTL Section Strings
---- ---- --- ------- -------
benstempher.nl TXT 3599 Answer {v=spf1
include:spf.protection.outlook.com -all}
benstempher.nl TXT 3599 Answer {MS=ms31874311}

Ik zie dat in je DNS Records, de SPF record niet zodanig ingesteld is om mails vanuit de website te vertrouwen.

Verander de SPF record naar:
code:
v=spf1 include:spf.protection.outlook.com ip4:213.75.21.16 -all


Wacht vervolgens 3354 seconden, hierna zal het moeten werken.

Het probleem in "normale taal":
Het lijkt er op dat de mail niet aan komt in verband met spamfiltering, dit gezien het adres van de server niet in de SPF(Een controle van betrouwbaarheid) record staat vermeld.

Ik adviseer tevens om de TTL tijdelijk te verlagen, zodat je sneller wijzigingen kan doorvoeren/fouten corrigeren. Nadat alles werkt is het aan te raden om de TTL weer te verhogen.
Beste SjorsK

Kan het bestaande niet wijzigen.
Heb het derhalve gedeactiveerd en een nieuw record geschreven zoals U omschreven hebt.
Echter hierbij staat dat het geen systeem record is maar een manual.
Is dat bezwaarlijk?
Het werkt nog niet moet ik zeggen.
Gisterenavond aangemaakt en vanochtend geprobeerd, maar helaas

Frans
Reputatie 7
Badge +6
Ik heb even van buitenaf een de informatie opgevraagd en dit is het antwoord wat ik krijg:
code:
benstempher.nl	TXT	830	Answer	{v=spf1 include:spf.protection.outlook.com ip4:213.75.21.16 -all}	


Alles lijkt nu correct ingesteld 🙂

Heb je ook gewacht voordat je het ging testen? Het duurt namelijk een tijdje voordat de DNS records "ververst" zijn, hoe lang dat duurt is afhankelijk van de TTL
Beste Sjors

Heb gisterenavond de wijziging doorgevoerd.
Vannacht heerlijk geslapen
Da's toch wel lang genoeg
TTL op 1500 gezet
What' s going wrong?

Frans
Reputatie 7
Badge +6
Hoi Frans,

De DNS moet nu wel goed zitten, krijg je een specifieke foutmelding wanneer de mail verzonden wordt?
Beste Sjors.

Eerstens.
Elke keer als ik op dit blog wil reageren wordt mijn ww en inlognaam niet geaccepteerd, erg frustrerend.
Moet ik weer via wachtwoord vergeten een nieuwe intypen.

Testmail wordt wel verstuurd
Ook testformulier op website wordt verstuurd
Geen van beiden komen aan

Krijg geen foutmelding
meldingen:
Testmail php is verstuurd en controleer Uw mailbox
Formulier: Hartelijk dank voor het invullen....ect ect...

Helaas.
Zo te zien zit er nog wel wat fout

Reputatie 7
Badge +6
Ik zit zelf dieper te troubleshooten in de security & compliance tool van office365, hier kan je achterhalen of het door de office365 systemen überhaupt ontvangen is (Voordat het door een filter wordt afgevoerd). Ik wil je graag de exacte instructies geven maar de tool werkt op dit moment even niet in mijn tentant.

Je kan bij de tool komen via:
  • Ga naar portal.office.com
  • Ga naar de admin center
  • Ga naar Reports -> Security & Compliance
  • Dan zou het onder Protection protection moeten staan, helaas willen die pagina's bij mij nu niet laden dus moet ik je de rest van de handleiding voorlopig schuldig blijven. Ik denk zelf dat het onder Spam Detections, Sent & Recieved mail of spoof mail report valt.
Reputatie 7
Badge +6
Nog een tip, voeg het IP adres hier in:
https://protection.office.com/#/antispam

Ga naar Custom -> Zet Custom Settings op "ON" en onder "Connection Filter Policy" voeg je 213.75.21.16 toe aan de whitelist.

Goedendag Sjors
Ook deze optie al uitgevoerd.
Ik weet niet waar ik nog moet zoeken.
Werkt nog steeds niet

Frans
Reputatie 7
Badge +6
Aan de kant van office365 is alles nu prima in orde.

Heb je toegang tot de logboeken van de server? Mogelijk dat het formulier zegt dat het goed is verzonden maar dat de e-mail er nooit is uitgegaan. De logboeken kunnen hier duidelijkheid aan geven.
Ik ga effe kijken
Het logfile error in Joomla htdocs geeft 1697 recods aan met foutmeldigen, allen betreffende :
Hier de de laatste 3
2017-04-25T10:32:59+00:00 INFO 125.212.224.198 joomlafailure De combinatie van gebruikersnaam en wachtwoord is niet correct of u heeft nog geen account.
2017-04-25T10:33:00+00:00 INFO 125.212.224.198 joomlafailure De combinatie van gebruikersnaam en wachtwoord is niet correct of u heeft nog geen account.
2017-04-25T10:33:01+00:00 INFO 125.212.224.198 joomlafailure De combinatie van gebruikersnaam en wachtwoord is niet correct of u heeft nog geen account.
Dit gaat zo door tot aan record 1 startend vanaf 24 maart 2017
Reputatie 7
Badge +6
Dat is een verkeerde logfile waarin je kan zien dat mensen het wachtwoord van de site willen raden 🙂
Geef mij een hint waar te zoeken.:?
Reputatie 7
Badge +6
Ik weet eerlijk gezegd niet of je er toegang toe hebt. Het is afhankelijk van de configuratie of je er überhaupt toegang toe hebt, Mogelijk kan een webcare medewerker die vraag beantwoorden 🙂
Wel, we zijn nu bijna een week verder.
De Joomla versie die KPN aanbiedt via de cloud app is sterk verouderd.
Heb 2x een migratie moeten uitvoeren tot aan de huidige versie.
Of hier iets fout is gegaan kan ik niet zeggen.
Heb via quickstart een nieuwe versie van Joomla geïnstalleerd. WT-Boss-J3x-Joomla-Quickstart-1.0.6, samen met template.
PHP draait nu prima.
Mails en formulieren komen nu aan.
Voor bezoekers aan dit item is dit jammer genoeg geen technische oplossing.
Ik ben blij dat het weer werkt.
Dank Sjors voor de support anywhere
Frans🆒
Reputatie 7
Badge +6
Fijn dat het weer werkt Frans 🙂 Ik denk eerlijk gezegt dat het probleem een combinatie van factoren was 🙂

Reageer