Beantwoord

flows have no logging

  • 19 May 2021
  • 6 reacties
  • 54 keer bekeken

I have a functioning LoraWAN device, I see data in the device-section, but none of the two flows I tried push out data to my server. There is no logging, so it is very hard to troubleshoot. Please add:

  • logging of flows, it’s a black hole now.
  • normal certificate-support, and report failure on this if not supported.
  • non-secure transports for testing.
  • simulate test-messages with logging output.

or point me in the right direction.

I tried https POST and MQTT to no avail, no error-messages and no diagnostics.

icon

Beste antwoord door Rick S. 21 May 2021, 16:32

Bekijk origineel

6 reacties

Reputatie 7
Badge +6

Goodmorning @kpnthings,


Welcome to the IoT Community!

Thank you for creating this topic. We are happy to help you. 
I tried to check your Things Portal account to see what is going wrong, but i couldn't find the account. 

 

Can you please send me your username of the Things Portal account?

Hi Rick,

my name is Joost Helberg, which is what the profile says after logging in into my Things Portal.  I log in using

kpnlora8385@cistus.nl

I’ve got the HTTPS POST flow kind a working now, except for the illegal senml I receive. I dont think it is allowed to leave out v and s and vs in an item. My Senml parser bombs out on the first item reading: {"bn": "urn:dev:DEVEUI:A84041D86182B195:", "bt": 1621517065}, as one of vs, s, v is missing. Or did I miss something in the RFC?

Still no luck getting mqtt to work. Without any logging, things are hard to debug.

thanks in advance if you can help.

Reputatie 7
Badge +6

Hi Joost, 

Thanks for the clarification! 
We found your account and we checked what is going wrong. I see that you also created the topic geen value in eerste senml item lijkt niet conform RFC8428. In this topic you will find the answer to your question about the HTTPS Post. 
 

We also looked at the MQTT server. The first thing we see is that this destination is currently not activated in the Things Portal. Everything else seems to be in order. So if you activate the MQTT broker in the Portal, the messages should arrive.

the destination is activated now, but there is no connect to my mqtt-broker, so I don’t think it will work. That’s why I am testing the http POST endpoint now. Can you see enything going wrong?

Wow, i’ve seen messages coming in via MQTT now. Don’t know why it didn’t work the first time, but I’m happier now. 

Reputatie 7
Badge +6

Hi Joost, 

Great to read that the MQTT now works! 
 

Reageer