Vraag

Lora https Post does not work

  • 24 februari 2020
  • 16 reacties
  • 497 keer bekeken

  • Adviseur
  • 14 reacties

I managed to connect a device. I can send and receive data. 

But the https plugin does not seem to work. I get no data on my end point.

I also tried with weblink but also no data.

SO i wonder if i understand it correct : each time i send data from my device i should receive a post on my end point right?

How can i check this ? I see no log for the plug. 

I followed all the steps from the docs. I am glad that sending/receiving data was so simple. But the devil is in the details :-)

thanks!
mark

 


16 reacties

Reputatie 6
Badge +6

Hi @mcs,

Welcome to the IoT Community! 
Off course we are going to help you with your issues. First of all, if I am right you connected a device in the KPN Things Portal instead of the LoRa Developer Portal?

And can you please tell me which steps you took?

 

Thanks for your reply. Of course i used the KPN Things portal.

I read all the documentation, then i followed all the steps.  And finally i programmed a device and exchanged some data. 

But the problem is that the https plug does nothing. Then i tried the webhook site but that also did not give any data.

So i can send data and i can see it in my account but i do not get any callback to the https plugin. 

I also do not get any location data, at least i do not see it in the Lora Message Logger. 

So how can i debug this?

I like to add that when i use curl the webhook receives data.  So receiving data is not the problem.

I just think that the plugin does not send a thing. I have read that it was broke some time ago. But then i guess that when something is broken many users would notice? Are there any users using this plugin with success?

when i looked to the plugin i got this message : A server side error occured. Our engineers have been notified.

So i guess someone is looking/fixing it.

And now i see this :  The Plug's Groups cannot be fetched

ok, i see the server error is fixed : the plugs belong to a group. again.

But still no data received on the web link.

 

Reputatie 6
Badge +6

Goodmorning @mcs,

I've asked one the KPN Things Specialists to help us with this issue. 
My colleague couldn't directly find errors, but he mentioned that you've used the ‘LoRa Geo decoder.’ 
We want to ask you if you would like to try the ‘No payload decoder’. Can you please test this? 

You can activate this decoder with the following steps: 

  1. Go to Project
  2. Project Details
  3. Activate decoder
  4. No payload decoder

 

Hi Rick

thanks for looking into this.

I changed the decoder as suggested but still i do not get any data from the plugin.

I tested the webhook with curl and also using sgfox and it works correct. 

I also see my data arriving. So maybe you can look into a log file ? I assume you do have some log files :-)

I decided to remove the device and add it again.

Now it works !

Have no clue since all settings appear to be the same.

It would be nice if there would be a log somewhere.

i got no geo data while i activated both decoders. but i look into that later.

Reputatie 6
Badge +6

Hi @mcs ,

Here I am again! 
I received the feedback that the device was actually connected for the first time last Wednesday (after deleting and adding again). In addition, my colleague saw that 2 messages have been sent that have arrived successfully on the webhook. If you go to 'All Devices' in the portal, you will see at the bottom the messages that went through the LoRa network. There you can see, for example, that the device has actually been connected since Wednesday evening.

hi Rick

yes that is what i wrote. after i deleted and recreated it worked. the messages were working all the time, that was not the problem. the https post was the problem. 

One thing does not work yet : i do not get any geo location. is it supposed to work? if so, how can i get location data?

Reputatie 6
Badge +6

Hi @mcs ,

My colleague was very busy. I'm sorry for the delay!
We’ve checked the settings and it should work. The Geolocation Decoder is activated and so the LoRa network should add the location. The striking thing is that we do not see new messages from this device since the 2 messages we have seen before (see my previous message). 

If the device has sent a number of messages and the location decoder is on, it will show the location.

 

hi RIck

thanks. yes i continued with sigfox. it is much cheaper than lora. i will use lora for my own ptp connection.

I appreciate the support. But i conclude that the prices are too high and that the reliability is too low. nbiot is more reliable but requires more expensive modules. there is no free lunch :-)

best regards

Mark

Hi,

It seems that I’ve got the same problem: Data from my device is coming in, but no HTTPS call is made. Flow is configured as mentioned in the Getting Started. Also tried to delete and add the device again (as topic starter did), but no luck for me.

Feature requests are logging and a test button for Destinations (or Flows) ;-).

Hope you can help me on this!

 

Reputatie 6
Badge +6

Hi @sventertainment , 

Thanks for your message!

We've checked your configuration and it looks good. We think that the data is not arriving because there is a space in the additional header configuration of the destination. This makes that the HTTPS call is invalid. Can you change this and check if it works after this change? 

In addition, we are in the process of introducing a logging tab on the destination detail page. With this tab these kind of issues should immediately become visible.

YES, that did the job!

 

Hope the logging feature is coming in real soon, so we can solve such (...) mistakes ourselves ;-).

 

Thank you!

Reageer