Vraag

Lora join verloopt ?

  • 8 juli 2020
  • 3 reacties
  • 125 keer bekeken

  • Participant
  • 4 reacties

We hebben een aantal units in fieldtest. Van deze units stopt het ontvangen van LORA berichten op willekeurige basis.

De units joinen bij start-up. en zenden 4 x per uur een bericht. 

Sommige units werken weken goed en vallen dan plots “weg”,  van andere krijgen wij al na 1 of 2 dagen geen bericht meer binnen. 

De units zelf lijken overigens wel te zenden. Na een herstart (re-join) werkt het weer, voor een bepaalde tijd.

Is dit wegvallen een normaal verschijnsel ?

(Deze units vragen nooit voor een acknowledge dus constateren zelf niet of een nieuwe join nodig is. Momenteel wordt de firmware aangepast zodat de unit elk 10e bericht vraagt voor ack, en zonodig een rejoin  doet.)


3 reacties

Reputatie 6
Badge +6

Goedemorgen @SWP,

 Excuses voor de zeer late reactie! 
Ik heb mijn collega's gevraagd om mee te kijken en het duurde even voordat ik hier een terugkoppeling van kreeg. Nu is het zo dat mijn collega's uw devices niet terug hebben kunnen vinden en dus niet heel ver in hebben kunnen zoomen. Kunt u mij een privébericht sturen met de devices waar het omgaat en uw gebruikernaam/mailadres waarmee u in de Things Portal geregistreerd bent?

Reputatie 6
Badge +6

Goedemorgen @SWP ,

Bedankt voor uw toelichting in uw privébericht! 
Als we het hebben over devices die via een abonnement bij Simpoint lopen, dan is Simpoint officieel ook het aanspreekpunt voor support. We willen u natuurlijk niet zomaar wegsturen, dus mijn collega is wel even op onderzoek gegaan. 

Het is alleen niet direct duidelijk waar het precies misgaat. In de historische meldingen van de devices met nieuwe firmware (devices met DevEUI eindigend ECA7 en 866F) staan meerdere meldingen van een DevNonce replay (laatste meldingen van 18-5 en 19-5). Bij een DevNonce replay hergebruikt het device een DevNonce-waarde tijdens het joinen, waardoor het netwerk de nieuwe join niet zal accepteren. Als het device vervolgens aanneemt dat de join wel gelukt is, dan zou dat een reden kunnen zijn dat het netwerk de berichten van het device niet meer accepteert.

Bij het derde device (DevEUI eindigend op A384) zien we deze meldingen niet. Dit device is op 13-6 om 9:15 en om 11:30 nog opnieuw verbonden met het netwerk, nadat hij een berichtencounter van 185 had bereikt. Na de eerste join komt het device tot een counter van 9, daarna tot 2 en vanaf 13-6 om 12:00 uur zien we geen berichten meer van het device, ook geen join-pogingen meer. Dat gedrag herkennen we alleen maar van devices waarvan de batterij uitvalt of die zijn DevAddr, AppSKey of NwkSKey vergeet en niet opnieuw joint.

Dank voor de info. De nieuwe firmware lijkt vooralsnog goed te werken. De units met deze firmware blijven data zenden.

M.vr.gr.

Ralf Thijssen

Reageer