Beantwoord

OTAA Join

  • 12 februari 2020
  • 7 reacties
  • 169 keer bekeken

Beste KPN,

Ik probeer data te verzenden via het kpn things lora netwerk.
Helaas krijg ik een timeout na het versturen van een join request.
De request kan ik wel zien in de portal. Hierdoor heb ik een aantal vragen.

Ik zie dat het bereik aan de lage kant is kan het hiermee te maken hebben? 
Is het device goed aangemeld via OTAA?
Moet ik op een bepaalde poort luisteren voor het antwoord?

Alvast bedankt

icon

Beste antwoord door Rick S. 13 februari 2020, 16:27

Hi @VincentD ,

Ik heb zojuist contact gehad met een van mijn collega's en we kunnen u in ieder geval goed op weg helpen. Er kunnen namelijk verschillende redenen zijn waarom een join request niet voltooid wordt. Gelukkig is het wel mogelijk om middels de LoRa Message History het probleem te debuggen. Om hierbij te ondersteunen hebben we de F.A.Q. My LoRa device won't join the network gemaakt. 

Als u alleen de join request en geen join accept in de message history ziet, heeft het vermoedelijk te maken met de Appkey die in het device staat. Daar zit vermoedelijk de fout in. 
 

Bekijk origineel

7 reacties

Reputatie 6
Badge +6

Goedemiddag @VincentD , 

Welkom bij de IoT Community! 
Allereerst wil ik even melden dat ik uw vraag naar het KPN Things forum heb verplaatst. 

Daarnaast moet ik even een hulplijn inschakelen om antwoord te kunnen geven op uw vragen. Ik wil u hiervoor vragen om mij te laten weten met welk mailadres uw Things Portal account geregistreerd is en om welk device het precies gaat zodat we gericht op onderzoek kunnen. 
 

Ik hoor graag van u!

Hey Rick,

Gebruikte email adres is: vincentDekens@outlook.com.
 

DevEUI

0059AC00001B00DB

UUID

204cc9fe-9ad7-496d-bc6d-8f18c473ce87

Name

testDev1

 

Momenteel heb ik maar 1 device beschikbaar om mee te kunnen testen

Reputatie 6
Badge +6

Goedemorgen @VincentD ,

Bedankt voor de gegevens! 
Ik zet dit gelijk door naar de specialisten zodat zij dit na kunnen kijken. Als ik een terugkoppeling ontvang hoort u gelijk weer van mij! 

Reputatie 6
Badge +6

Hi @VincentD ,

Ik heb zojuist contact gehad met een van mijn collega's en we kunnen u in ieder geval goed op weg helpen. Er kunnen namelijk verschillende redenen zijn waarom een join request niet voltooid wordt. Gelukkig is het wel mogelijk om middels de LoRa Message History het probleem te debuggen. Om hierbij te ondersteunen hebben we de F.A.Q. My LoRa device won't join the network gemaakt. 

Als u alleen de join request en geen join accept in de message history ziet, heeft het vermoedelijk te maken met de Appkey die in het device staat. Daar zit vermoedelijk de fout in. 
 

Als u alleen de join request en geen join accept in de message history ziet, heeft het vermoedelijk te maken met de Appkey die in het device staat. Daar zit vermoedelijk de fout in. 


Ik zie inderdaad geen join accept onder het kopje "LoRa message logger” staan, alleen join requests.

Kunnen jullie zien welke appKey ik gebruik en of zou moeten gebruiken?

Naar mijn weten zou ik appKey 
0xd9, 0x3a, 0x14, 0x87, 0x5d, 0x49, 0xd1, 0xcf, 0x37, 0xbe, 0x51, 0x48, 0x9a, 0xb0, 0x60, 0xfa
moeten gebruiken. Deze heb ik nu zowel mbs als lsb geprobeerd, maar met beide geen succes behaald.

Ziet ernaar uit dat ik heb kunnen joinen met jullie netwerk.

Lag inderdaad aan de appKey (meeerdere variabelen die werden gebruikt voor de appKey in de voorbeeldcode).

Bedankt voor de hulp

Reputatie 6
Badge +6

Goedemiddag @VincentD ,

Excuses voor mijn late reactie! 
Ik heb uw bericht afgelopen vrijdagmiddag helemaal gemist. 

Goed om te lezen dat het inmiddels gelukt is. Als u nog andere vragen heeft hoor ik het graag :grin:

Reageer