Vraag

Underscores not allowed in URL path

  • 24 April 2023
  • 4 reacties
  • 70 keer bekeken

My web hook URL is rejected when configuring an HTTPS endpoint:

URL is required. It should start with the HTTP secure protocol (https://), followed by a valid domain and optionally a path. A valid domain contains a period (.), and cannot contain an underscore (_).

The abbriviated URL is:

https://hooks.nabu.casa/gAAA40DkE_9cH6P...

And it contains an underscore in the path and not in the domain. 
The underscore should be allowed in the path.
I can’t change the path at the hooks.
nabu.casa site. This is automatically generated.

How to solve this?

 

 


4 reacties

Reputatie 7
Badge +6

Goodmorning @Hans Meent,

Welcome to the IoT community!
We are of course happy to think along with you. I searched based on the information from the forum profile and I think I found the Things Portal account based on your email address. In this account I see an active device and an active HTTPS Endpoint with a webhook destination. Do I understand correctly that you are now trying to create a (2nd) new endpoint?

Hi Rick,

This morning found two ways to avoid the error:

1 First enter URL without path, Save, Edit again and enter full path

2 Use escape character %5F instead of the underscore. Should not be required according to specs but it works.

I get my data in Home Assistant so problem is solved.

Thanks, Hans

Reputatie 7
Badge +6

Hey Hans, 

Thanks for your reaction! 

Great to hear that you found these ‘workarounds’. I will share the feedback with the specialists, so they can correct the documentation. If we can help you with any other questions, please let us know.

Hi, I saw your post and I was curious about your issue with underscores in URL path. I did some research and I found out that underscores are not recommended for SEO purposes, because they are treated as word characters by search engines, while hyphens are treated as word separators. This means that using underscores can make your URLs less readable and less discoverable by potential users. I suggest you try using hyphens instead of underscores and see if that solves your problem. If you need any help with web development, you can check out CodeIT, a software company that offers web development services using the latest technologies and best practices. They have a lot of experience working with different platforms, and they can help you create a fast, secure, and user-friendly website. You can find more information about their services here: https://codeit.us/services/web-development-services

Reageer