Vraag

vragen configureren LoRa

  • 21 november 2019
  • 4 reacties
  • 235 keer bekeken

  • Actieve Deelnemer
  • 8 reacties

Beste KPN,

 

Graag wil ik proberen om mijn LoRa devices te koppelen met het KPN netwerk.

Vandaar dat ik me heb aangemeld op de developers portal. Twee maal zelfs. Eenmaal via de KPN LoRa developer portal en een maal via de KPN Beta Things Portal.

Op beide portals heb ik een device toegevoegd met verschillend resultaat, maar beide niet succesvol.

KPN LoRa developer portal:

Op deze portal heb ik een OTAA device toegevoegd en mijn eigen Applicatie Server URL als destination opgegeven.

Als ik via het Edit device scherm een Uplink test uitvoer is deze succesvol. Het bericht komt ook binnen op mijn AS.

De downlink test is niet succesvol. Ik krijg de volgende foutmelding:

Error in sending downlink message for device 0018B20000001DB9, payloadhex 000000. Error details: restservices.consume.RestConsumeException 351. Rest request failed: [HTTP Request: POST '?' --> Response status: 351 null, ETag: null, body: 'Invalid DevEUI']

Het lijkt of mijn device niet bekend is in het netwerk.

KPN Things Portal

Op deze portal heb ik een ander device toegevoegd via OTAA. Dit is succesvol. Ik zie de berichten die ik via mijn device verstuur binnenkomen in de “Advanced dat history” van de portal.

Kan ik via de Things Portal ook mijn eigen applicatie server aansluiten? Het lijkt erop dat je alleen cloudoplossingen kunt gebruiken.

Desondanks heb ik mijn Applicatie Server via een Plug proberen toe te voegen. Hiervoor heb ik plugtype HTTPSSENML gebruikt met HTTP method “Post” en de URL mijn applicatie server toegevoegd. Als ik van mijn Applicatie server een berichtje probeer te versturen naar mijn device krijg ik volgende melding: “Status: 350 Msg: Security Check. bad AS_ID Id: 2019-11-20 14:55:24.483-2035”.

Ik vermoed dat ik niet de juiste methode heb gebruikt om mijn Applicatie server te koppelen.

Hoe kan ik in beide gevallen mijn connectiviteit werkend krijgen? Aangezien beide portals een eigen forum hebben zal ik deze post even op beide plaatsen.

Groet

Fons


4 reacties

Reputatie 6
Badge +6

Goedemiddag @fonsv ,

Bedankt voor uw vraag! 
Zoals ik ook al even in mijn reactie op het LoRa Forum liet weten ga ik voor het stuk mbt de KPN Things Portal gelijk een hulplijn inschakelen. Ik heb zelf namelijk nog weinig ervaring en kennis van deze portal en ik wil u uiteraard wel gelijk goed helpen.

Hoi Rick,

dank je. Ben benieuwd naar je reactie..

groet Fons

Reputatie 6
Badge +6

Goedemorgen @fonsv ,

Ik heb een terugkoppeling gekregen van de specialisten op het gebied van de Things Portal. Zij vertelde mij dat de LoRa Downlink op dit moment nog niet beschikbaar is in de Things Portal. Achter de schermen wordt keihard gewerkt om het zsm te introduceren. Dat gaat dus niet heel lang meer duren. 

Daarnaast heb ik nog wat extra vragen gesteld met betrekking tot het gebruik van een eigen Applicatie Server en het aansluiten/koppelen van de server. Daar kom ik dus nog even op terug:wink:

Reputatie 6
Badge +6

Goedemiddag @fonsv ,

Daar ben ik weer! 
Allereerst moet ik zeggen dat de methode die u gebruikt heeft (HTTPSSENML) om de applicatie server aan te sluiten helemaal goed is. Op dit moment is het zo dat alleen de uplink berichten worden doorgestuurd naar de applicatie. Het is nog niet mogelijk om downlinkberichten terug te laten sturen. Dit verklaart ook de foutmeldingen die u kreeg. Vermoedelijk wordt het voor het einde van het jaar nog mogelijk om via de Portal downlinks te sturen. Volgend jaar pakken we door met downlinks vanuit de applicaties. 

 

Ik hoop u hiermee voldoende geïnformeerd te hebben!  

Reageer