Vraag

Application Server Setup

  • 5 december 2018
  • 6 reacties
  • 741 keer bekeken

Hello Madam/Sir,
I am trying to set up the application server for the LoRA network for testing.
This is what I get when I send messages to test the application server.

Error in sending rest post to developer url https://lora.delftengineers.nl/lora, for device 0059AC0000181CC8, payloadhex 000000. Error details: com.mendix.modules.microflowengine.MicroflowException 500: Internal Server Error at DevLoRa_UpLink.SendExactLoraMessToDev (CallRest : 'Call REST (POST)') at DeviceMngmt.SendTestUplinkMessage (SubMicroflow : 'SendExactLoraMessToDev') at DeviceMngmt.IVK_SendTestMessage (SubMicroflow : 'SendTestUplinkMessage') Advanced stacktrace:

Is it necessary that I remove the username and password set for accessing the specified location?

Thanks and Regards,
Santhosh Shetty

6 reacties

Reputatie 6
Badge +6
Hi @Santhosh Shetty,

Welcome to our IoT community!
First, I must tell you that we can not give you a full service about the application server. We are responsible for the connection with our network. But of course I will try to help you with this problem. The first thing that strikes to me is that https://lora.delftengineers.nl/lora does not work. If you visit this site, you will get an internal server error. Did you notice this error?

Furthermore, I will discuss this problem with our specialists, so that we can help you and steer you in the right direction.
Hi Rick,

Thank you for this information. Yes, I noticed this error. If I go to https://lora.delftengineers.nl , it says no permission to access this. Maybe this is the issue.

I have the hostname, username and password to access this location via an application like FileZilla, but can I not provide the same in KPN website to make it more secure?

Thanks and Regards,
Santhosh
Dear Sir/Madam,

My name is Santhosh and I am writing from Delft Engineers. We are looking to set up an IOT device network (around 10000 devices) on the KPN LoRA network. For this, we would like to test the KPN LoRA network. I have signed up for the trial version from KPN.

However, I am facing difficulties in setting up the application server, specifically in providing the right configuration. I would like to request your help in setting up the same as I have tried everything as specified in the documentation but I still receive HTTP fail errors.

Thanks and Regards,
Santhosh
Reputatie 6
Badge +6
Hi Santosh,

I went to research and have our specialists take part. I found your account and noticed that your device's status is 'Error'.

Now it appears that there is a block on the device because from the network MAC commands are sent to the device. These MAC Commands must be 'acknowledged' by the device.
Hi Rick,
This device is not switched on permanently. I switch it on only during testing. I just tested the downlink for the device. The status is correct and shows a green tick mark.
However, on testing the uplink for the server, I get the attached image (left hand side):
From the debugger window below (attached image

right hand side), we know that the device is sending information (GPS coordinates) to uplink. It also received the downlink payload sent as test from the Edit Device page of KPN LoRA Developer Portal.

The issue I am facing with the application server portal (https://lora.delftengineers.nl/ - is accessible now). As shown in the second image, the application server is inaccessible. Please help me solve this issue. I have also left my phone contact number in the email to iot@kpn.com so it is easier to contact me.

Thanks and Regards,
Santhosh Shetty
Reputatie 6
Badge +6
Hi Santosh,

Thanks for your message!
It's not completely clear to me where this is going wrong. So far, we know that the device doesn't acknowledge the MAC commands that are sent to the device from the network.

So I suggest that we check step by step where it went the wrong way. Firstly, did you check the documentation in the topic Setting up your Application Server?

Furthermore, when the Application Server is not reachable I advise you to check the topic Application Server SSL certificates and authentication tokens. Finally, we also have several LoRa tools and reference code to help us with these kind of issues. You find the reference code in the topic There are LoRa tools and reference code available to make your life easier.

Good Luck!

Reageer