Beantwoord

Downlink message via Lora Developers portal komt niet aan

  • 4 juni 2018
  • 6 reacties
  • 422 keer bekeken

In mijn pogingen het Lora netwerk te testen is het vrij eenvoudig gelukt een uplink message naar mijn applicatie te sturen. De volgende stap is een downlink message.
Ik gebruik een arduino uno met een Dragino shield en de LMIC library van IBM.
Bij het zenden van de testmassage krijg ik response 200, met de melding dat de message is gequeud.
Ik heb al getest of ik op b.v. SF7 kn zenden en dat lukt. De dekking blijkt goed.
Ik gebruik SF9 in mijn RX2.
Na drie avonden zoeken op fora en andere sites kom ik geen steek verder. Hebben jullie ideeën om verder te zoeken. Zijn er instelling die ik over het hoofd heb gezien?
Groeten
Elfred van Nieuwamerongen
icon

Beste antwoord door Elfred 10 juni 2018, 15:37

Na lang zoeken, proberen, frustreren en leren, is het dan uiteindelijk gelukt. Op de dragino Lora Shield is het van belang DIO5 open te zetten.
Groeten
Elfred
Bekijk origineel

6 reacties

Reputatie 6
Badge +6
Goedemorgen @Elfred,

Welkom bij de IoT Community!
Goed om te lezen dat het gelukt is met een uplink message. Natuurlijk help ik graag verder met de downlinks messages.
Ik heb op uw naam het Developer Portal account gevonden en zie verschillende devices naar voren komen. Nu ben ik even benieuwd om welk device het precies gaat. Kunt u mij het DevEUI van het betreffende device sturen?
Jazeker,
Het gaat om DevEUI 14203707
Dank
Groeten
Elfred
Reputatie 6
Badge +6
Hi @Elfred,

Bedankt voor uw reactie!
Ik ben op onderzoek gegaan en heb de situatie met een van mijn collega's besproken.
Wanneer u een test downlink verstuurd via de Developer Portal krijgt u als response dat het bericht klaar staat. Dat gaat tot zover goed. De volgende stap is vervolgens dat het device de downlink binnen moet halen. Hierbij moeten we eigenlijk even uitzoeken wanneer het device downlink berichten binnen kan halen. Ik ben daarom erg benieuwd wat voor Class het device heeft. In het topic LoRaWAN Device Classes: A, B and C vind u hier meer uitleg over.
Rick,
Het classe A,B en C fenomeen is mij bekend. Ik heb een klasse A device (Dragino shield).
Ik verwacht mijn berichtje dan ook na een transmit. Ik weet niet zeker of ik die in de RX1 timeslot kan verwachten of in RX2. Is het nog van belang welke settings ik daarvoor instel?

Groeten
Elfred
Na lang zoeken, proberen, frustreren en leren, is het dan uiteindelijk gelukt. Op de dragino Lora Shield is het van belang DIO5 open te zetten.
Groeten
Elfred
Reputatie 6
Badge +6
Goedemiddag @Elfred,

Zoals u ongetwijfeld gemerkt heeft werken wij niet in het weekend. Vandaar mijn late reactie!
Ik ben erg blij om te lezen dat het inmiddels gelukt is. Stiekem hadden mijn collega en ik het vermoeden dat het in het device zat. Het lastige is echter dat wij zelf niet over hardware gaan en het dan dus een lastige puzzel blijkt te zijn. Gelukkig is deze nu opgelost! Mocht u nog andere vragen hebben, u bent altijd van harte welkom op het forum 😁

Reageer