Beantwoord

Hoe contact herstellen van MARVIN naar Netwerk?


Na exact 1 maand experimenteren met (MARVIN+SHT31)+KPNDevPortal+MendixDashboard, zie ik na herinstallatie op het DevPortal na een laatste experiment nog slechts 1 uplink en daarna niets meer.
Sketch is onveranderd en laad & reageert goed, en settings op Portal en Dashboard zijn onveranderd t.o.v. reeksen met goede werking. Maar op het Dashboard komt niets meer door.
Als ik op het DevPortal onder Edit 'Test Uplink' probeer, dan krijg ik de volgende respons
Server returned HTTP response code -1
Response info:
Error in sending rest post to developer url https://mansystemsiot.mendixcloud.com/lora, for device 0059AC0000181004, payloadhex 000000. Error details: com.mendix.modules.microflowengine.MicroflowException 400: Bad Request at DevLoRa_UpLink.SendExactLoraMessToDev (CallRest : 'Call REST (POST)') at DeviceMngmt.SendTestUplinkMessage (SubMicroflow : 'SendExactLoraMessToDev') at DeviceMngmt.IVK_SendTestMessage (SubMicroflow : 'SendTestUplinkMessage') Advanced stacktrace:

Hoe herstel ik contact tussen MARVIN en het LoRa-netwerk?
icon

Beste antwoord door Tln07 27 februari 2019, 09:12

Waarneming tijdens experimenten:
steeds SF12 en RSSI -100 e.d. Lijkt te wijzen op een dekking die niet geweldig is, en dat in een stedelijke woonwijk .....

Met nog wat hulp van TTN-Forumleden nu een werkende functionele oplossing die zowel stand-alone goed werkt, als ook in verbinding met de seriële interface van de PC: inbouw van een vertraging.
Er blijkt maar een kleine aanpassing nodig in de sketch die je vanuit de Marvin-webpagina's krijgt aangereikt:

code:
Serial.begin(9600);
while (!Serial && millis() < 10000);
Bekijk origineel

9 reacties

Reputatie 6
Badge +6
Goedemiddag @Tln07 ,

Welkom bij de Iot Community!
Ik heb uw account en het device bekeken. Ik zie hem nu met een error naar voren komen, maar het is mij niet gelijk duidelijk hoe dit komt. Ik ga dit daarom aan onze specialisten voorleggen. Als ik een terugkoppeling heb hoort u direct weer van mij!
@Rick S.

Probeer hier MARVIN continu aan te houden met een KPN-gerichte sketch die SHT31-data verzendt.

Zie je wel berichten van het device binnenkomen op het Portal?
Dan is tenminste de eerste stap gemaakt vanaf het device via een gateway naar het KPN-netwerk,
en hoeven we 'alleen maar' uit te vinden waarom dat berichtenverkeer fout gaat.
Zo niet, dan is het nodig uit te vinden waar in dat traject het überhaupt mis gaat met de communicatie.

MVG, Tln07
'Eerst een maand verbinding, en dan niet meer' daagt uit, zeker als een aantal weken zonder problemen ook stand-alone met eenzelfde sketch is gewerkt, met voeding vanuit een USB-powerpack.
Vandaag de Marvin aan de PC gekoppeld waarop de Arduino-IDE waarmee de sketch is geupload.
Weer uncomment bij de scriptregel gezet waarbij SF12 wordt afgedwongen, dus vrije keus voor SF..
Via Arduino-IDE/ Hulpmiddelen/ Seriële Monitor nog eens gekeken naar responses, en dan krijg ik nu wel verbinding ........
In de Debugger van het DevPortal zichtbare binnenkomst van uplinks (met SF12), en ook doorgifte van de data naar MendixDashboard.
Maar als ik de Marvin-setup weer aansluit op een powerpack of USB-voeding, dan niets meer.
Weer aan de PC moet eerst de Arduino-IDE met de Seriële Monitor er bij komen voordat er weer leven komt.

Lijkt er op dat op nu een of andere manier de seriële verbinding tussen Marvin en de Arduino-IDE een kritische rol speelt.
Zouden de print-opdrachten naar de Console kunnen zijn, maar dan onbegrijpelijk dat het ook met dezelfde sketch in Marvin stand-alone gewerkt heeft.
😞 Of mis ik hier iets als Newbie ......
Reputatie 6
Badge +6
Goedemiddag,

Een van de specialisten is op onderzoek uit om tot de oplossing te komen.
Ik zorg ervoor dat dit als aanvullende informatie wordt meegenomen.

Zodra ik een terugkoppeling ontvang kom ik uiteraard direct bij u terug!
Misschien heb ik (met hulp van TTN-Forumleden) een gedeeltelijke oplossing gevonden :
zie https://www.thethingsnetwork.org/forum/t/how-to-check-operation-of-lora-enddevice/22947/8

Daarmee krijg ik nu enerzijds standalone wel verbinding met het LoRa-netwerk, maar anderzijds blokkeert nu (als ik Marvin aan de PC hang) 'iets anders' de werking van de serial,print-functie. Ergens een 'if' op de verkeerde plaats?

😉 Effecten van de learning-curve?
Waarneming tijdens experimenten:
steeds SF12 en RSSI -100 e.d. Lijkt te wijzen op een dekking die niet geweldig is, en dat in een stedelijke woonwijk .....

Met nog wat hulp van TTN-Forumleden nu een werkende functionele oplossing die zowel stand-alone goed werkt, als ook in verbinding met de seriële interface van de PC: inbouw van een vertraging.
Er blijkt maar een kleine aanpassing nodig in de sketch die je vanuit de Marvin-webpagina's krijgt aangereikt:

code:
Serial.begin(9600);
while (!Serial && millis() < 10000);
Reputatie 6
Badge +6
Goedemorgen @Tln07 ,

Wat super goed dat u het zelf heeft op kunnen lossen!
Ik moet eerlijk zeggen dat ik niet precies weet wat er bij ons aan de hand is. Ik zit namelijk nog steeds op een terugkoppeling te wachten. Mijn excuses hiervoor!

Kan ik u wellicht met andere zaken hebben?
Tja, de verbinding werkt nu, maar met 2 weken gaat de uplink-verbinding met MendixDashboard op slot.
Voor die tijd moet ik ergens een andere Destnation-URL vinden waar ik permanent de json-file van de Marvin kan ophalen:
suggesties/voorbeelden voor een eenvoudige invulling zijn zeer welkom.
Zodat ik de resterende tijd op het KPN DevPortal verder kan uitproberen op een werkende verbinding.

Heb inmiddels wel een account in de IBMCloud/Bluemix, maar nu nog verder invullen ...........
Reputatie 6
Badge +6
Goedemorgen,

Vanuit KPN kunnen we u niet adviseren m.b.t. de Application server of de destination URL die u gebruikt.
Tijdens het testen is het uiteraard wel mogelijk om gebruik te maken van een tool als Beeceptor.

In het topic Setting up your Application Server vind u meer informatie over het opzetten van uw Application server.

Reageer