Beantwoord

LoRa Class C OTAA


Hallo,

Ik ben bezig geweest met een LoRa node in klasse C te activeren op het KPN netwerk. Nu is dit alleen nog gelukt wanneer ik gebruik maak van ABP i.p.v. OTAA waarvan geadviseerd wordt om gebruik van te maken. Ik heb met de device manager op Thingspark de node toegevoegd met het "Device profile: Semtech LoRaMote fw3 Class C" waarbij ik OTAA geconfigureerd heb zoals ik dat ook voor klasse A doe. Sterker nog wanneer ik van hetzelfde 'Device profile' (Class C) gebruik maak maar de node configureer als een klasse A node kan ik met OTAA direct met het KPN netwerk verbinden. Het probleem lijkt dan in eerste instantie aan de node te liggen echter wanneer ik de node geconfigureerd heb voor klasse C & OTAA kan ik zonder problemen verbinden met onze 'Kerlink' prive netwerk. Hieruit blijkt dat het probleem bij KPN ligt.

Verder valt er op dat er op de KPN device manager er bij het 'Device profile' ook gekozen kan worden voor 'Semtech LoRaMote fw3 Class A Join' en voor 'Semtech LoRaMote fw3 Class A' met het verschil dat het profiel met Join bedoeld is voor een OTAA node? Voor een klasse C node is een profiel met Join echter niet beschikbaar. Betekent dit dat er geen gebruik kan worden gemaakt van OTAA wanneer een node in klasse C staat geconfigureerd?
icon

Beste antwoord door Rick S. 13 september 2017, 10:05

Goedemorgen @Xkottelaar en @robkleinee,

Zoals gezegd ben ik in gesprek gegaan met de specialisten. Het klopt dat er problemen zijn geweest met het activeren van een node geconfigureerd in klasse C. Echter zijn de problemen nu opgelost en moet het lukken. Let op, hiervoor moet het device wel firmware versie 1.3 hebben, dus wellicht is er een update van de firmware nodig.

Laat u mij weten of het gelukt is?

Bekijk origineel

8 reacties

Ik heb ook problemen om mijn node met class C te laten joinen met het KPN netwerk. Zijn er mensen die dit wel is gelukt?
Reputatie 6
Badge +6
Hi @Xkottelaar,

Welkom bij onze LoRa Community! 😁

U stelt een erg goede vraag, waar ik niet direct het antwoord heb. Het klopt dat er op de Developer Portal (de testomgeving) alleen OTAA gebruikt kan worden met een klasse A node. Echter doelt u natuurlijk op het gebruik op het daadwerkelijke KPN netwerk. Ik zet deze vraag uit en ga in gesprek met de specialisten.

Natuurlijk kom ik direct bij u terug als ik meer weet!
Hi @Rick S.,

Bedankt voor uw reactie! Het gaat inderdaad om het daadwerkelijke KPN netwerk waarop ik mijn node in klasse C d.m.v. OTAA wil activeren.

Ik ben benieuwd naar uw antwoord!
Reputatie 6
Badge +6
Goedemorgen @Xkottelaar en @robkleinee,

Zoals gezegd ben ik in gesprek gegaan met de specialisten. Het klopt dat er problemen zijn geweest met het activeren van een node geconfigureerd in klasse C. Echter zijn de problemen nu opgelost en moet het lukken. Let op, hiervoor moet het device wel firmware versie 1.3 hebben, dus wellicht is er een update van de firmware nodig.

Laat u mij weten of het gelukt is?
@Rick S..

Goed om te weten dat het in ieder geval zou moeten werken. Ik ga verder kijken wat het probleem kan zijn aan mijn kant, te beginnen met het updaten van de LoRa stack. Ik zal laten weten of dit het probleem oplost.
Reputatie 6
Badge +6
Hi @Xkottelaar,

Helemaal goed!
Ik ben erg benieuwd of het gaat lukken en zie uw terugkoppeling graag verschijnen 😁
@Rick S.,

Het updaten van de LoRa stack heeft het probleem verholpen! Ik kan nu zonder problemen met het KPN netwerk verbinden met OTAA en Klasse C.

Nog bedankt voor uw hulp en advies!
Reputatie 6
Badge +6
Goedemiddag @Xkottelaar,

Dat is heel goed nieuws!
Bedankt voor de terugkoppeling, daar heeft @robkleinee ook wat aan 😁

Als er in de toekomst nog iets is, trek aan de bel!

En een goed weekend alvast 😎

Reageer