Vraag

OTAA activation werkt niet

  • 19 november 2018
  • 4 reacties
  • 736 keer bekeken

code:
Goedemorgen KPN,

Wij hebben een KPN LoRa Developer Licenties en hebben een LORA knop in beheer van http://www.alloralivinglab.org/products/push/ deze hebben wij afgelopen vrijdag 16 november voor het eerst geprobeerd te koppelen aan het portaal https://loradeveloper.mendixcloud.com onder de naam lora button
Tot op heden hebben wij nog geen verbinding tot stand kunnen brengen tussen het IOT device en jullie portaal over het LORA netwerk.
De test met de downlink krijgen wij Response:
Response info:
Error in sending downlink message for device 70B3D5EE1186008A, payloadhex 000000. Error details: restservices.consume.RestConsumeException 351. Rest request failed: [HTTP Request: POST '?' --> Response status: 351 null, ETag: null, body: 'Invalid DevEUI']
Wij bevinden ons zelf in spankeren met de lora knop.
Kunnen jullie mee kijken wat er mis gaat en wij handteren activation method OTAA.
Alvast vriendelijk bedankt.

Met vriendelijke groet,
Wesley Dekker

4 reacties

Reputatie 6
Badge +6
Goedemorgen @wesdek ,

Welkom bij de IoT Community!
Wat tof om te lezen dat u aan de slag bent gegaan met de LoRa Push button op ons netwerk. Ik had deze button nog niet eerder gezien.

Aan de foutmelding die u krijgt te zien loopt het vast op de DevEUI die er gebruikt wordt. Nu is het zo dat een ongeldige DevEUI namelijk ook helemaal niet ter goedkeuring doorkomt als er een Join Request wordt gedaan via OTAA. Nu zie ik het device wel in uw Developer Portal account naar voren komen met de status 'Error'. Weet u of deze DevEUI officieel geregistreerd is (welke ook in het device geregistreerd staat)?
Goedemiddag @Rick S. ,

Ja zeker deze heb ik 3 keer gecontroleerd zelfs en volgens de leverancier staat het volgende ingesteld op de knop.
DEV EUI: 70B3D5EE1186008A
APP EUI: 70B3D5EE1F180726
APP KEY: E09C7A60C4B8EAE6FFFA26DD2E67431E


Met vriendelijke groet,
Wesley Dekker
Reputatie 6
Badge +6
Goedemiddag Wesley,

Bedankt voor uw snelle reactie!
Hmm dat maakt het wel erg vreemd dat u de foutmelding krijgt dat de DevEUI niet geldig is. Ik ga dit voorleggen aan onze specialisten, want ik loop zelf ook wat vast. Ik kom hier op terug!
Reputatie 6
Badge +6
Goedemorgen @wesdek ,

Daar ben ik weer!
We zijn met een aantal specialisten aan de slag gegaan en zijn een stuk verder.
Het lijkt erop dat u een downlink naar het device probeert te sturen, maar dat het device nog niet op het netwerk aangemeld is. Het is daarom dus eerst zaak om een Join procedure te volgen, zodat u vervolgens een downlink kunt sturen. Dit verklaart ook de error 'invalid DevEUI'.

Daarnaast valt het op dat er een AppEUI vermeld staat. Deze is anders dan de AppEUI die we op de Developer Portal gebruiken. En op de Developer Portal kan alleen de AppEUI, die in de documentatie op de Developer Portal beschreven staat. gebruikt worden.

Hopelijk kunt u hiermee verder!

Reageer