Beantwoord

Payload onleesbaar bij KPN, maar bij concurrent provider niet

  • 4 mei 2018
  • 6 reacties
  • 402 keer bekeken

Wij zijn bezig met tests van Lora devices en hadden tot nu toe geen problemen met meerdere merken devices op zowel Lora KPN als van een concurrent. We gebruiken nu even de devices onder APB en niet OTAA. Wij hebben een voorkeur voor KPN vanwege de hoogte waarop de gateway antennes staan, waardoor onze laag bij de grond devices makkelijker verbinding maken.

Nu hebben we met een merk device echter een vreemd probleem. De meta data is goed leesbaar maar de payload data zelf is een puinhoop. Het vreemde is echter dat hetzelfde device het met de concurrent provider het perfect doet (APB, alleen andere keys). Andere merken devices krijgen we zowel op KPN als de concurrent goed binnen, zowel metadata als payload.

Mijn vraag: zitten er in de lorawan mogelijk verschillende versies , waardoor er compatibiliteits problemen optreden, waardoor payload verminkt wordt en niet de metadata ?

ps de KPN lora keys zijn van onze zakelijke accounts

met vriendelijke groet
Koen
icon

Beste antwoord door koenver 10 mei 2018, 21:58

Het was inderdaad een Fport probleem. Deze stond op Fport2 en blijkbaar werkt dat dus niet met individuele business keys van S***oint (kpn Lora). BIj de devices was deze niet instelbaar..maar de fabrikant heeft me vandaag nieuwe firmware gestuurd.. (nadat ik een voorstel van source code wijziging in github had voor gesteld...hij wist niet dat ik wist waar dat stond 🙂. ). en nu loopt de boel als een tierelier op Fport=1



Het was dat ik met mijn hobby gateway de data opving en kon decoderen en toen viel het op... Nu kunnen we gelukkig verde met de praktijk test op KPN Lora bedrijfsmatig. Voor business toepassing zitten we liever bedrijfsmatig bij een business provider 😀





dus problem solved



wel dus uitkijken met onebekende devices..je zoekt je een ongeluk waar het probleem zit...

binnen kort kom ik wel op een ander KPN forum naar boven...ga ook spelen met LTE-M
Bekijk origineel

6 reacties

Reputatie 7
Badge +11
Dag Koen,

Goed om te lezen dat u kiest voor het KPN netwerk voor uw LoRa verkeer! 😉

Het klinkt als een probleem in de versleuteling, gezien de meta data correct is en de payload er anders uitziet dan verwacht. Om die reden lijkt er iets mis te gaan met de decryptie. Of is de payload onvolledig?

Maakt u gebruik van de developer portal? Hoeveel devices hebben dit probleem? Wat is het exacte type en merk device?
Tim,
De payload is volledig (aantal bytes). En het gebeurt alleen bij een bepaald merk device type LoraST. Op zich een ideaal device als je ziet hoe extreem zuinig dit ding werkt. (200nA is slaap en kan wake-up interrupt aan). Het probleem is dat je deze devices moet configureren met keys via terminal verbinding, zodat ik niet zie wat er direct onder de moterkap plaatsvindt. in tegenstelling tot mijn hobby dingen , waarbij ik de keys in de firmware mee compileer.

We hebben commerciele keys gekocht via simpoint en gebruiken het developer portal niet. (ik wist niet dat je met developer portal ook met commerciele keys kon werken).

Even voor duidelijkheid ..voor de hobby zit ik bij de concurrent, maar professioneel (grote E-net beheerder) werken wij liever met KPN en zijn wat POC's aan het draaien. Wel kan ik met mijn concurrent gateway de payload ge-encrypt zien die het device naar KPN zendt (...eens kijken of dat decodeerbaar is met de keys )

Koen
Tim,
Zojuist met mijn concurrent gateway de zend signalen opgevangen en de geencrypte payload m.b.v. kpn keys gedecodeerd met https://lorawan-packet-decoder-0ta6puiniaut.runkit.sh/ , de verzonden payload is leesbaar (gewoon netjes LPP cayenne codering zichtbaar met de realistische getallen in de gedecodeerde payload).

Waar gaat het mis ?? Als je bij KPN werkt stuur me even een bericht dan krijg je mijn email en kan ik je nog meer metadata en keys laten zien, zodat jullie eens verder kunnen snuffelen (moet wel een KPN email zijn)

koen
Reputatie 3
Badge
Hi koenver,

Ik heb je zojuist een privébericht gestuurd, omdat ik graag even op device niveau met je mee wil kijken.

Groet,
Lennart
Het was inderdaad een Fport probleem. Deze stond op Fport2 en blijkbaar werkt dat dus niet met individuele business keys van S***oint (kpn Lora). BIj de devices was deze niet instelbaar..maar de fabrikant heeft me vandaag nieuwe firmware gestuurd.. (nadat ik een voorstel van source code wijziging in github had voor gesteld...hij wist niet dat ik wist waar dat stond 🙂. ). en nu loopt de boel als een tierelier op Fport=1

Het was dat ik met mijn hobby gateway de data opving en kon decoderen en toen viel het op... Nu kunnen we gelukkig verde met de praktijk test op KPN Lora bedrijfsmatig. Voor business toepassing zitten we liever bedrijfsmatig bij een business provider 😀


dus problem solved

wel dus uitkijken met onebekende devices..je zoekt je een ongeluk waar het probleem zit...
binnen kort kom ik wel op een ander KPN forum naar boven...ga ook spelen met LTE-M
Reputatie 7
Badge +11
Super! Bedankt voor uw terugkoppeling @koenver, fijn dat het goed werkt en de oplossing hier gedeeld is. Veel succes! 😀

Reageer