Vraag

Server returned HTTP response code 0

  • 15 oktober 2018
  • 10 reacties
  • 759 keer bekeken

Op dit moment ben ik aan het proberen om een Pycom LoPy te verbinden met het KPN developers portaal aan de hand van de documentatie code. Ik krijg het apparaat nog echter niet via OTAA gejoined.

Om de data te verwerken heb ik een kleine PHP applicatie gemaakt. Zodra ik een uplink test, krijg ik de foutmelding "Server returned HTTP response code 0". Dit terwijl de test-gegevens wel gewoon goed aankomen op mijn server. De "Count Unreacable" loopt ook niet op. Ondanks dat ik hier lees dat dezelfde foutmelding bij iemand anders geen problemen oplevert, zie ik wel dat er een rood kruisje in de status kolom komt te staan zodra de foutmelding voor het eerst voorkomt..

Kan het zijn dat mijn uitdaging iets met deze foutmelding te maken heeft of gaat er echt iets mis bij de LoPy zelf?

10 reacties

Reputatie 3
Badge
Hier hetzelfde gehad. Heb je als eens met een node getest? Daarna komt het er een groen vinkje.
Dankjewel Bas! Ik heb het nu via ABP geprobeerd en hiermee krijg ik inderdaad het resultaat wat je beschrijft. Het is nu dus duidelijk dat het niet aan de foutmelding ligt. Het joinen doormiddel van OTAA wil echter nog niet lukken.

KPN: Ik lees op het forum heel veel posts over mensen die ook problemen hadden met het joinen doormiddel van OTAA. Vaak ging er dan achter de schermen iets niet helemaal lekker. Zou dat hier ook het geval kunnen zijn of hebben jullie misschien een richting waarin ik kan zoeken om het probleem op te lossen?

Alvast bedankt voor het meedenken!
Reputatie 3
Badge
Ik heb toevallig sinds een haf jaar de LoRa spullen er weer bijgepakt. Ben in de tussentijd druk geweest te testen met NB IoT van T mobile.

Ik ga vd week even testen met OTAA. Er waren idd wat problemen hiermee op de Dev Portal. Wat daar nog actueel van is durf ik niet te zeggen.

Ik vind dat de dev portal ook ondermaats gedocumenteerd is. Zo kwam ik er vandaag achter dat je max 6 berichten per uur kunt versturen vanaf je LoRa node. ☹

Verder is er weinig activiteit nog op het forum. Ik denk dat veel mensen bij het begin zijn afgehaakt. Vaak goede ideeen maar door gebrek documentatie en voorbeelden valt het voor de meeste tegen helaas.
Reputatie 6
Badge +6
Goedemorgen @Vic Luijkx,

Aan de hand van uw mailadres heb ik uw account in de Developer Portal opgezocht en ik zie inderdaad uw ABP en OTAA device naar voren komen. Het OTAA device heeft op dit moment de status 'Error'. Nu wil ik graag de OTAA aanmelding volgen. Ik heb daarom dit device (DevEUI 70B3D54991A2F9C3) nu van de Portal verwijderd. Ik wil u vragen om een nieuw OTAA Join Request aan te maken en mij dan een seintje te geven. Ik check dan of deze goed doorkomt.
Dag @Rick , Ik heb net rond 12:38 een Join Request aangemaakt.
Reputatie 6
Badge +6
Goedemiddag @Vic Luijkx,

Bedankt voor de melding!
Tot mijn verbazing zie ik het device met het OTAA Join Request niet in de portal terugkomen.
Ik ga bij de specialisten navragen hoe dit kan en hoe we dit op kunnen lossen.

Ik kom bij u terug!
Reputatie 6
Badge +6
Goedemiddag @Vic Luijkx,

Ik heb zojuist van de specialisten begrepen dat er vanaf gisterochtend 10.00 uur een storing was op de Developer Portal. Dit kan er ook voor gezorgd hebben dat het Join Request niet door komt. We zijn nu bij de ontwikkelaar aan het uitzoeken of de storing inmiddels helemaal verholpen is. Zodra we er zeker van zijn dat de storing verholpen is kunnen we een nieuwe poging doen.
Reputatie 6
Badge +6
Goedemiddag @Vic Luijkx,

Ik kreeg zojuist het signaal dat de portal weer helemaal werkt en dat de OTAA Join Requests weer doorkomen. WIlt u aub nog een poging doen en een nieuw Join Request doen?
Mooi! Ik heb vanaf vanmiddag 12:38 een aantal OTAA Join Requests aangemaakt.
Reputatie 6
Badge +6
Goedemiddag Vic,

Bedankt voor uw bericht!
Ik ben bang dat er toch iets misgaat in de aanmelding die u doet. Ik zie het Join Request namelijk wederom niet terugkomen in de Developer Portal. Wilt u mij een printscreen sturen met wat u ingevuld heeft voor de aanmelding?

Deze stuur ik dan door naar de specialisten, zodat we gerichter kunnen kijken wat er misgaat. U kunt het hier in privé sturen, maar u kunt het ook mailen naar zakelijkforum@kpn.com.

Reageer