Beantwoord

Where to find AppEUI

  • 18 February 2017
  • 49 reacties
  • 2567 keer bekeken

Reputatie 3
Badge
We are currently testing with OTAA.
Bur where can i find the AppEUI in the developer portal?

I found the Dev EUI and the Appskey.
icon

Beste antwoord door Jeroen10 1 May 2017, 09:09

Bekijk origineel

49 reacties

Reputatie 1
Badge
It worked for me, the device got connected
Reputatie 1
Badge
OTAA is now available on the developer portal. I have recently registered on the portal and registered a node for OTA activation yesterday but I haven't received AppEUI keys. How and when do I get these keys?
Reputatie 7
Badge +11
I notice that the user interface of the developer portal looks slightly different, @Tim can you confirm that the portal was updated somewhere in the last one or two days and/or that an issue with OTAA has been resolved?
Well, that really seems to be an coincidence. I think they forgot to activate your device after the OTAA join request was processed. We've set your device manually to activated on friday 🙂
Reputatie 1
Badge
Hello

Any answer for this topic.

I want to test OTAA. On the device I need to configure the Device EUI, App Key and App EUI.

Where can I get the App Key and App EUI. ?

Regards
Reputatie 1
Badge
no that s all I did

the app key i had to make manually but it had to be of a certain minimum lenght otherwise it doesnt get provisioned in the device
@Tim
When wil de app eui be shown in the developer platform?
Could you send me the app eui. We want to run some tests.
Reputatie 3
Badge +1
@Robg66 you should use 0059AC0000010120 as AppEUI. This is now also described in the documentation on the developer portal.
Reputatie 1
Badge
@Tim I corraborate user @Jeroen10's suggestion.
Reputatie 1
Badge
@Jeroen10 Today I tried using OTAA again and to my surprise it works (without me changing anything, just powering the LoRa device).

I notice that the user interface of the developer portal looks slightly different, @Tim can you confirm that the portal was updated somewhere in the last one or two days and/or that an issue with OTAA has been resolved?
Reputatie 1
Badge
Thanks @Tim. In the mean time I added several OTAA nodes and they all activated within a few minutes from registering. So I'm happy with that.
@TimHi Tim, kan je mij ook de APPEUI geven van de developer portal? Groet, Jeroen
Reputatie 7
Badge +11
Hi Bas,
We don't support OTAA yet from the developer portal. At the moment it's only possible to register manually (ABP keys). When OTAA will become available, KPN will deliver the AppEUI keys.
Reputatie 7
Badge +11
Hello @IAS & @Jeroen10,

The release information about the update can be found here.
For OTAA the AppEUI's are used, but are hidden in the developer portal.

Are you both looking for the AppEUI's for production tests?
Reputatie 7
Badge +11
@Jeroen10 & @IAS We're looking into this right now. I'm wondering if you already tried what happens if you'll leave the OTAA value blank? Or when you try a random key (made-up)? 🙂
Reputatie 7
Badge +11
Sorry, yes I meant the AppEUI key :$
Thanks for the info, Probably it won't work either when you'll leave the parameter blank.
Reputatie 7
Badge +11
I've sent everybody who posted in this topic the AppEUI for the developer portal.
At least, I hope I've got it right :$

If you're looking for the key, please post in this topic 🙂
Reputatie 7
Badge +11
Is the AppEUI for all OTAA devices the same?
@IAS can you connect with the given AppEUI?

Yes it is indeed the same for everyone and all devices. :)
The key will soon be found in the developer portal.

Great to hear it's working for @Amine Mouadden MBA!
@Jeroen10 it seems you got the same error message as before with no AppEUI filled?
Reputatie 7
Badge +11
Hi @Jeroen10, the AppEUI is working for me! It should be correct.
Have you got any progress?
Reputatie 7
Badge +11
@DvdGiessen In a future update of the developer portal, the APP_EUI will be shown in the portal. I'll send you the key in a private message.
Reputatie 7
Badge +11
Thanks @Tim. In the mean time I added several OTAA nodes and they all activated within a few minutes from registering. So I'm happy with that.
Great, good to hear it's working well 😃
Reputatie 7
Badge +11
Hello @DenDeze, something is definitely going wrong here. When I look at our OTAA join requests, the last registration on the Developer Portal was like a week ago. So the join requests haven't reached our end.

This can be due to old firmware on your device. Is there new firmware available? To be honest, this is the first LoPy I´ve seen, so I don´t have any experience with this device.
Reputatie 7
Badge +11
Hi @DenDeze, I've just used a keyword query on LoPy, and many of these devices have already been logged on to our network. Some of these have been registered by OTAA. I expect it to work for you too as well.

Maybe i've found the problem. The Dev EUI 0059AC0000010120 is already activated on an expired account and have been activated with OTAA before. This account isn't active for 1,5 months now. I think this is the reason. Did you take over this device from a former owner? Can you try again? I've removed the device now.
Reputatie 7
Badge +11
Hi @DenDeze Right, I may have read your post incorrectly. The AppKey can be made up and must be 16 bytes long, you don't need to use the same value as AppEUI for that. When I look at some random devices, it looks like you can put any value there. I've seen 1111111111111 but also 12345 or any other random value. Make sure you have enough signal to sent the join request, can you try again and let me know what error message you're got returned?
Reputatie 7
Badge +11
Hi @DenDeze, it seems we still haven't got an OTAA join request from your device..
My suggestion is we let one of our specialist take a look, if you have any valuable information to provide us, please let me know. Can you sent me a private message with your contact details?
Reputatie 7
Badge +11
Hi @JeroenD, de AppEUI voor de developer portal is 0059AC0000010120
Succes!

Reageer