Beantwoord

Where to find AppEUI

  • 18 februari 2017
  • 49 reacties
  • 2178 keer bekeken

Reputatie 3
Badge
We are currently testing with OTAA.
Bur where can i find the AppEUI in the developer portal?

I found the Dev EUI and the Appskey.
icon

Beste antwoord door Jeroen10 1 mei 2017, 09:09

@Robg66 you should use 0059AC0000010120 as AppEUI. This is now also described in the documentation on the developer portal.
Bekijk origineel

49 reacties

Reputatie 3
Badge
@tim. Maybee you can help me where i can find this key.
Reputatie 7
Badge +11
Hi Bas,
We don't support OTAA yet from the developer portal. At the moment it's only possible to register manually (ABP keys). When OTAA will become available, KPN will deliver the AppEUI keys.
Reputatie 1
Badge
OTAA is now available on the developer portal. I have recently registered on the portal and registered a node for OTA activation yesterday but I haven't received AppEUI keys. How and when do I get these keys?
Reputatie 3
Badge +1
I've got the same question as @IAS. Since OTAA only recently added to the Developer Portal there is no documentation / Tutorial / information available yet.
Reputatie 7
Badge +11
Hello @IAS & @Jeroen10,

The release information about the update can be found here.
For OTAA the AppEUI's are used, but are hidden in the developer portal.

Are you both looking for the AppEUI's for production tests?
Reputatie 1
Badge
I'm looking for AppEUI's for testing AND for production because a number of devices are ready for permanent deployment if OTAA testing is successful (and my other problem with SSL is resolved).
Reputatie 3
Badge +1
@Tim to setup a connection via OTAA with the RN2483 you have to give the AppKey, AppEUI and DevEUI as parameters. I want to know If I can get up and running with OTAA because that is the way to go if we want to go to the real LoRa platform, and if there are any differences in the communication, and test encryption options.
Reputatie 7
Badge +11
@Jeroen10 & @IAS We're looking into this right now. I'm wondering if you already tried what happens if you'll leave the OTAA value blank? Or when you try a random key (made-up)? 🙂
Reputatie 1
Badge
@Tim Which "OTAA value" do you mean?

I've added a random AppEui to one of my nodes and it doesn't connect or show up in the debugging. When I use SF7 ABP firmware on the same node then I see the messages coming in, so OTAA not working is not a range problem.

Microchip RN2483:
mac set deveui 0004A30B0019691C
mac set appeui 0662E9027DDA707A
mac set appkey 0662E9027DDA707A86F917FCFCF8E411
mac set adr on
mac join otaa
denied


DevEUI & AppKey are copied from the 'devices' page on the portal.
Reputatie 7
Badge +11
Sorry, yes I meant the AppEUI key :$
Thanks for the info, Probably it won't work either when you'll leave the parameter blank.
Reputatie 3
Badge +1
@Tim I already tried with a random AppEUI. I get the following output:

Port open
[initOTA]
[init]
[sleep]
[wakeUp]
[resetDevice]
[expectString] expecting RN.(RN2483 0.9.5 Mar 24 2015 14:15:33) found a match!
The device type is RN2483
[setPowerIndex]
[setMacParam] pwridx = 1
[expectString] expecting ok.(ok) found a match!
[setSpreadingFactor]
[setMacParam] dr = 5
[expectString] expecting ok.(ok) found a match!
[setMacParam] deveui = [array][expectString] expecting ok.(ok) found a match!
[setMacParam] appeui = [array][expectString] expecting ok.(ok) found a match!
[setMacParam] appkey = [array][expectString] expecting ok.(ok) found a match!
[setMacParam] adr = on
[expectString] expecting ok.(ok) found a match!
[joinNetwork]
[expectString] expecting ok.(ok) found a match!
[expectString] expecting accepted.......(denied)Error loading network settings!
Reputatie 3
Badge +1
@Tim any updates? Or can you send @IAS and me the hidden AppEUI and then look for a common solution?
Reputatie 1
Badge
@Tim I corraborate user @Jeroen10's suggestion.
Reputatie 1
Badge
Hello

Any answer for this topic.

I want to test OTAA. On the device I need to configure the Device EUI, App Key and App EUI.

Where can I get the App Key and App EUI. ?

Regards
Reputatie 7
Badge +11
I've sent everybody who posted in this topic the AppEUI for the developer portal.
At least, I hope I've got it right :$

If you're looking for the key, please post in this topic 🙂
Hi Tim,

We need to test OTAA on the dev portal too. Please provide us with the AppEUI too.

Cheers,

Mark
Reputatie 3
Badge +1
I still can't join the network via OTAA.

[joinNetwork]
[expectString] expecting ok.(ok) found a match!
[expectString] expecting accepted.......(denied)Error loading network settings!

Is the AppEUI for all OTAA devices the same?
@IAS can you connect with the given AppEUI?
Reputatie 1
Badge
It worked for me, the device got connected
Reputatie 7
Badge +11
Is the AppEUI for all OTAA devices the same?
@IAS can you connect with the given AppEUI?

Yes it is indeed the same for everyone and all devices. :)
The key will soon be found in the developer portal.

Great to hear it's working for @Amine Mouadden MBA!
@Jeroen10 it seems you got the same error message as before with no AppEUI filled?
Reputatie 3
Badge +1
Yes, still the same error. @Tim can you check the AppEUI one more time? I already triple checked the AppKey and DevEUI.
Reputatie 7
Badge +11
Hi @Jeroen10, the AppEUI is working for me! It should be correct.
Have you got any progress?
@Tim, any updates on making the APP_EUI available? I was trying out the KPN developer portal, but the lack of a APP_EUI is currently stopping me from evaluating the KPN LoRa network, so I'd be much interested in any update on the APP_EUI so I could run some evaluations. 🙂
Reputatie 7
Badge +11
@DvdGiessen In a future update of the developer portal, the APP_EUI will be shown in the portal. I'll send you the key in a private message.
Reputatie 1
Badge
Sorry for the late response, been away for some time. I tested OTAA just now and no success:
sys reset
RN2483 1.0.1 Dec 15 2015 09:38:09
mac set pwridx 1
ok
mac set dr 5
ok
mac set deveui 0004A30B0019691C
ok
mac set appeui xxxxxxxxxxxxx120
ok
mac set appkey 0662E9027DDA707A86F917FCFCF8E411
ok
mac set adr on
ok
mac join otaa
denied


DevEUI & AppKey correspond to the device settings. The AppEUI is as provided by @Tim

Any ideas?
Reputatie 3
Badge +1
@Tim I also still got the same problem as @IAS (denied). Is it possible the AppEUI only works with newly registered devices after you sent us the AppEUI? Is there something else we can try?
@Amine Mouadden MBA do you use the Developer Portal or the Thingpark network?

Reageer